
Photométrie avec AstroImageJ : 

premiers clics – prétraitement des images

Prérequis

Nous supposerons que vous maîtrisez les bases du traitement d’images en astronomie, et que les
principes de la photométrie ne vous sont pas étrangers. A défaut, il est conseillé de lire un tutoriel
précédemment  rédigé qui  donne  un  certain  nombre  de  conseils  pour  aborder  la  photométrie
lorsqu’on est totalement débutant en la matière.

Pour rappel, lors de chaque observation, en plus des images scientifiques (vos images stellaires
proprement dites), il vous faudra acquérir une série d’images d’offset (bias en anglais), une série de
darks, et une série de flats.

S’agissant de vos images scientifiques, vous prendrez le plus grand soin – en particulier – de ne 
saturer ni votre étoile cible ni vos étoiles de comparaison, en adoptant un temps d’exposition 
approprié : ni trop long, ni trop court. Des poses de 60 à 180 secondes, à voir selon votre matériel et
votre cible, feront généralement l’affaire. Au besoin, il est possible de diaphragmer votre optique, 
ou mieux, de défocaliser, si la cible est trop brillante. Réduire le temps de pose outre mesure 
n’amènera le plus souvent à rien de bon : le bruit augmente et la courbe est moins bonne. Si vous 
travaillez avec un APN, réduisez la sensibilité à 100 ou 200 iso, au maximum 400 iso.

 

La console AstroImageJ

A l’ouverture,  le  logiciel  affiche  une  console  quasi  microscopique,  mais  pour  autant  pleine  de
promesses.

Sous la barre des menus, sont disposées, en partant de la gauche, une première série de 12 icônes,
qui correspondent à des fonctions disponibles dans la « couche » ImageJ du logiciel  (voir  page
d’accueil de ce tutoriel), et au-delà, dans la partie droite, une deuxième série d’icônes, numérotées
de 1 à 8, qui permettent le contrôle de la partie astronomique du soft.
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Ouvrons une image quelconque (fichier .fit ou .fits) : menu File>Open.

Une nouvelle fenêtre s’ouvre, à l’intérieur de laquelle notre image est affichée. Nous pouvons, si
nous le souhaitons utiliser l’une ou l’autre des fonctions ImageJ pour dessiner sur notre image ou
pour y créer des annotations. Testons, par exemple, l’outil mesure d’angle, pour évaluer la position
d’une queue de comète (le résultat apparaît dans le bas de la console AIJ), puis sauvegardons le
résultat : menu (fenêtre d’affichage) File>Save image display as JPEG

Au-dessus  de l’image,  nous trouvons une série  d’une vingtaine d’icônes  dont nous détaillerons
progressivement l’usage. L’icône la plus à droite, située juste à côté des loupes, permet un réglage
automatique de la luminosité et du contraste de l’image. Cette fonction peut être fixée/modifiée
grâce au menu Scale de la fenêtre d’affichage.

Sous l’image, nous trouvons un histogramme qui peut nous permettre d’améliorer l’affichage de
notre image (déplacer latéralement les clips). Ces différents réglages ne modifient en rien notre
fichier image originel. Un clic droit directement dans l’image, en déplaçant le curseur en latéralité
D-G et/ou en verticalité Haut-Bas permet, avec un peu d’habitude, de régler très finement le couple
luminosité/contraste.

La documentation correspondant à ImageJ est disponible dans le menu Help>Documentation de la
console AIJ. Nous ne détaillerons pas davantage cette partie du logiciel qui ne nous sera utile que
très  épisodiquement.  Il  faut  néanmoins  savoir  que  de  très  nombreuses  fonctions  de  traitement
d’image se cachent dans les menus, y compris des fonctions mathématiques très poussées, dont les
astronomes sont en général très friands.

 



 Revenons maintenant aux fonctions astronomiques du logiciel, en cliquant sur l’icône 1 de la 
console. Nous pouvons alors zoomer/dézoomer dans notre image à l’aide de la roulette de la souris, 
et déplacer/recentrer l’image avec un glissé/clic gauche. Il est également possible d’utiliser les 
icônes loupes situées au-dessus de l’image.

Fermons maintenant la fenêtre image, et revenons à la console AIJ.

 

Voici une description sommaire des icônes 1 à 8 :

• Icône 1 – Cette icône indique par défaut que le mode « astro » est actif. 
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• Icône 2 – Mode photométrie d’ouverture simple. Un double clic sur cette icône ouvre le
panneau « Aperture photometry settings » (paramétrage de la photométrie). 

• Icône 3 – Mode photométrie « multi-ouverture ». Ce mode est essentiel dans AIJ. 
• Icône 4 – Nettoyage.  Un clic  sur  cette  icône remet  « à  zéro » la  fenêtre  d’affichage en

supprimant tous les labels et cercles d’ouverture actifs. 
• Icône 5 – Mode « multi-plot » : paramétrage et affichage des courbes de lumière. 
• Icône 6 – Ouverture d’une table de mesures précédemment sauvegardée. 
• Icône 7 – Accès au module de prétraitement d’images : DP ou « CCD Data processor ». 
• Icône 8 – Convertisseur de coordonnées : « Coordinate converter ». 

 

Prétraitement des images

Un clic sur l’icône 7 « DP » active l’affichage de deux nouvelles fenêtres :

• 1 – La fenêtre « CCD Data processor », qui permet le paramétrage du prétraitement des
séries d’images. Cette fenêtre agit également à la manière d’un script et permet, si on le
souhaite, d’aller au-delà du prétraitement et d’aborder l’analyse proprement dite des images
une fois le calibrage achevé. Cette fenêtre permet aussi de paramétrer le mode « pipeline ». 

• 2 –  La  fenêtre  « DP coordinate  converter »,  qui  permet  à  l’utilisateur  de  renseigner  le
logiciel sur quelques points essentiels tels que : coordonnées de l’observatoire et de la cible.
Ceci  permet  de prendre en compte la  valeur  « Airmass ».  Cette  fenêtre  est  peu ou prou
équivalente à celle qui s’affiche lorsque l’on clique sur l’icône 8. 

Il n’est pas absolument nécessaire d’effectuer le prétraitement des séries d’images sous AIJ. Des
images correctement calibrées à l’aide du soft fourni avec votre caméra, ou avec Iris, ou tout autre
logiciel, peuvent tout à fait être injectées en aval du module de prétraitement.

A ce propos, il est indispensable de noter qu’AIJ travaille en standard avec des fichiers .fit ou .fits,
qu’il reconnait les principaux formats graphiques (.jpeg, .png ./…), mais qu’il ne reconnait pas les
images de type RAW des APN. Les photométristes qui souhaitent analyser des images obtenues à
l’aide  d’un  APN  devront  au  préalable  convertir  leurs  fichiers  RAW  en  .fit  puis  effectuer  le
prétraitement avec IRIS.

Note : le menu File>Import permet d’importer en mémoire de nombreux types de fichiers image,
dont les fichiers .AVI, chers aux amateurs de webcam, et les fichiers RAW. Lorsqu’un tel fichier
RAW est sélectionné, une fenêtre s’ouvre qu’il s’agit de paramétrer. Des fichiers APN seraient ainsi
– éventuellement – déchiffrables via ce menu ; nous ne sommes toutefois pas parvenu à en ouvrir
un. Si un lecteur y parvient, merci de nous faire connaître la marche à suivre et nous nous ferons un
devoir de décrire la procédure ici-même.

Le module de prétraitement est assez simple à utiliser et plutôt intuitif, aussi nous ne nous étendrons
pas outre mesure.

Veuillez notez qu’à tout moment, une aide contextuelle peut être affichée en pointant le curseur
souris sur un item quelconque de la fenêtre active. Il faut pour cela que l’option Preferences>Show
tool  tips de la  fenêtre  « CCD Data Processor » soit  activée.  Le texte  est  en anglais,  comporte



parfois  d’assez nombreuses  lignes,  et  ne  demeure affiché  qu’un court  laps  de temps ;  de quoi
progresser rapidement en anglais.

Commençons par renseigner le  « DP coordinate converter ».

Dans la case « SIMBAD object ID », nous entrons simplement le nom de notre cible. Un appui sur
la touche ENTREE permet alors – en principe – d’interroger la base de données SIMBAD, qui est
sensée  nous  retourner  quelques  renseignements  sur  celle-ci,  notamment  ses  coordonnées.  Nous
disons en principe, car les quelques essais que nous avons effectués ne nous ont pas convaincu à
100% ; certaines cibles sont reconnues et pas d’autres (nous avons entré des noms de planètes, des
matricules d’étoiles au Henry Draper, des variables bien connues, et d’autres plus exotiques, ou de
découvertes récentes : KIC8462852). Il est en tout cas indispensable, dans le menu  Network, de
décocher l’option « Use harvard SIMBAD server« , pour permettre un accès direct au serveur CDS
de Strasbourg.

Lorsque SIMBAD demeure silencieux, il convient de remplir « à l’ancienne, et à la main » les deux
cases soulignées de vert : « SIMBAD RA et DEC » (coordonnées J2000 Eq). Il ne nous reste plus,
ensuite, qu’à entrer les coordonnées de notre observatoire et son altitude ; l’option « Custom Lon,
Lat … » doit être sélectionnées au menu « Observatory ID ».

Il est à noter que le fichier  « Observatories.txt », localisé dans le répertoire d’installation d’AIJ,
peut être édité avec un simple traitement de texte. Vous pourrez éventuellement en profiter pour
supprimer de la liste l’Observatoire de Pulkovo, si toutefois vous n’envisagiez pas d’y faire carrière.
Conserver  le  Pic  du  Midi,  ou  les  Gemini  North  &  South  apparaît,  en  revanche,  comme  une
excellente idée, ne serait-ce que pour le dépaysement.

Si vous oubliez de renseigner le « DP coordinate converter » avant le prétraitement, vous pourrez le
faire ultérieurement.

 



Nous pouvons maintenant reporter notre attention sur la fenêtre « CCD Data processor ».

Le haut de la fenêtre (« Science image processing ») nous permet d’indiquer au logiciel dans quel
répertoire se trouvent les images à traiter : il s’agit ici de c:\Observations. Dans ce répertoire, nous
avons regroupé 25 images  scientifiques, 16 images d’offset, 6  darks (c’est un peu juste, mais le
matériel dégoulinait littéralement de rosée tandis que l’observation s’achevait et nous avons préféré
en rester là), et 17 flats. Les fichiers sont respectivement nommés i1 à i25, o1 à o16, d1 à d6, et f1 à
f17, cela en .fit. Nous indiquons donc au logiciel qu’il trouvera les images sous les noms i*, o*, d*
et f*, tel que nous le montrons dans la copie d’écran ci-dessous.

AIJ retrouve automatiquement le nombre d’images placées dans le répertoire de travail. Les cases
« Enable » et « Sort num » doivent être cochées.

Lorsque toutes les images nécessaires au prétraitement sont regroupées dans un répertoire unique, il
n’est  pas  utile  de  remplir  les  autres  champs  correspondants,  s’agissant  des  parties « Bias
substraction », « Dark substraction » et « Flat division ».
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On cochera les cases « Build » et « Enable » dans les trois cas. Le prétraitement par « médiane » est
préférable, aussi gardera-t-on cochées les cases « Med ».

Si l’on utilise des darks qui n’ont pas le même temps d’exposition que nos images scientifiques, il
faudra en outre cocher la case « Scale » (dans la partie « Dark substraction »). Ce n’est pas le cas
ici, puisque nos darks sont peu nombreux, mais il ont été fait avec un temps d’exposition correct.
Cocher également « Debias » afin de soustraire l’offset des images de dark.

La  suppression d’un éventuel  gradient  dans  les  images  de  flat est  possible  :  cocher  « Remove
gradient ». Cette option ne nous a pas totalement convaincu, induisant potentiellement quelques
biais dans nos images calibrées. A voir au cas par cas, donc.

Il  reste  à  indiquer  au  logiciel  que  nous voulons  qu’il  sauvegarde  le  maître  offset sous  le  nom
moffset.fits, le maître dark sous le nom mdark.fits et le maître flat sous le nom mflat.fits.

Nous nous abstiendrons de faire appel aux fonctions de corrections d’images, afin d’écarter tout
risque d’introduction de biais dans nos images calibrées.

Nous indiquons au soft qu’il peut mettre à jour les entêtes de nos fichiers calibrés (« Fits Header
Updates » :  case  « General » cochée).  A ce sujet,  il  convient d’ouvrir le  « General Fits  header
settings panel », à savoir, la fenêtre qui contrôle le paramétrage des données qui seront introduites
dans l’entête (header) du fichier .fits à l’issue du prétraitement. Pour cela, cliquez sur l’icône « clé à
mollette »  qui  se  trouve  un  peu  à  droite  au  même  niveau,  puis  validez  ou  non  les  diverses
modifications à apporter aux entêtes. Ce qui est déjà renseigné en sortie de caméra par votre logiciel
d’acquisition n’a a priori pas besoin d’être modifié (cible, coordonnées de l’observatoire etc) et doit
être décoché. Si vous passez outre cette étape, il vous sera à nouveau possible un peu plus tard
d’éditer vos entêtes.

La case « Plate solve », qui amène à la réduction astrométrique des images, n’est pas cochée. Nous
nous occuperons de ceci ultérieurement.

Indiquez  au  soft  où  il  pourra  trouver  les  coordonnées  de  la  cible  :  soit  dans  le  « Coordinate
converter » que vous avez préalablement renseigné, ou que vous renseignerez plus tard, soit dans
l’entête des images. Même chose en ce qui concerne les coordonnées du lieu d’observation (menus
déroulants « Target coordinate source » et « Observatory location source ».

L’Icône « compas » fait disparaître/réapparaître le « Coordinate converter » à volonté ; il faut bien
trouver à s’amuser un peu en faisant de la science.

Enfin,  nous allons autoriser AIJ à sauvegarder les images calibrées – c’est  bien la moindre des
choses – en cochant la case « Enable » située juste sous le label  « Save calibrated images », puis
nous lui demanderons de renommer les images calibrées à partir du nom originel auquel sera ajouté,
par exemple, le suffixe « cal » (pour calibré).

Il est important d’indiquer où stocker les images issues de la calibration ; indiquez un donc un nom
de sous-répertoire dans la case ad hoc : case « Sub-dir » (sous-répertoire qui sera automatiquement
créé, s’il n’existe pas déjà). Je vous laisse le soin de deviner ce qui pourrait bien se produire, si vous
n’indiquiez aucun nom de sous-répertoire dans cette case. Comme je suis persuadé que vous allez
tenter le coup malgré tout, n’oubliez pas qu’il existe un bouton « Pause » …



Lorsque vous avez correctement rempli les diverses cases du « CCD data processor », vous pouvez
appuyer sur le bouton « Start ».

Si tout se passe bien, en quelques secondes à quelques dizaines de secondes, selon la quantité et la
taille des images à manipuler, le prétraitement est achevé.

That’s all folks !

Un petit mot à propos de la gestion de la mémoire.

Il  vous  faudra  très  probablement  éditer  le  fichier « AstroImageJ.cfg » qui  se  trouve  dans  le
répertoire d’installation d’AIJ,  et  modifier la quantité de mémoire que le logiciel  est  autorisé à
utiliser (par défaut 640 Mo), faute de quoi vous n’irez pas très loin. Pour cela, remplacez donc le
nombre  640 par  la  quantité  réellement disponible  sur  votre  système,  soit  75% de la  RAM, au
maximum, le reste étant nécessaire au système d’exploitation pour tourner.

Dans la mesure où ma machine dispose de 8 Go de RAM, j’autorise AIJ à utiliser 6000 Mo.

N’oubliez pas de sauvegarder le fichier .cfg et de relancer AIJ.
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